Atención usuarios de java: intervención manual necesaria antes de actualizar

Si se tiene instalado el paquete java-common, hace falta intervención manual del usuario para sortear un problema de conflicto entre ficheros. Se puede comprobar ejecutando el siguiente comando:

$ pacman -Q java-common
java-common ...

De ser así, antes de proceder con la actualización, hay que ejecutar lo siguiente:

# archlinux-java unset
# pacman -Sydd --asdeps java-runtime-common
:: java-runtime-common and java-common are in conflict. Remove java-common? [y/N] y
# archlinux-java fix

Una vez hecho esto, se puede proceder a actualizar:

# pacman -Su

Hay que tener en cuenta que el paquete java-runtime-common nuevo no usa ni soporta el forzado de JAVA_HOME como el antiguo java-common solía. Para más información, leer el artículo de la wiki sobre Java.

Traducción oficial y discusión de la noticia en el foro.